9L30 != 9L31a

Somehow I got out of sync with everyone else in the local distcc cluster at work. How? Weirdly, the XCode settings showed that while there were plenty of peers around to build with, they were all slightly off (har) in their OS version number, and therefore returned the dreaded “Incompatible Service”.

Some googling revealed that Apple shipped two 10.5.8’s!. A regular software-update won’t trigger the required update, either. Luckily, re-applying the stand-alone updater got me up to 9l31a, and I can once again abuse my co-worker’s CPUs instead of my own. Phew!